15 Introduction In Postprocessing with HyperView and HyperGraph

15.1 HyperView - Animating Results

In this chapter, you will learn how to:

- Use some features available for post-processing animation results in HyperView
- Control the display of the simulation results using Entity Attributes

The tables below show the animation use-cases and the model and results file types required to animate MotionSolve results.

<table>
<thead>
<tr>
<th>Use Case</th>
<th>Parts in Model</th>
<th>Model File</th>
<th>Results File</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transient</td>
<td>Purely rigid</td>
<td>H3D</td>
<td>H3D</td>
</tr>
<tr>
<td>Transient</td>
<td>One or more flexible bodies</td>
<td>H3D</td>
<td>H3D</td>
</tr>
<tr>
<td>Modal</td>
<td>Purely rigid</td>
<td>MAF</td>
<td>MRF</td>
</tr>
<tr>
<td>Modal</td>
<td>One or more flexible bodies</td>
<td>MAF</td>
<td>MRF</td>
</tr>
</tbody>
</table>

In order to display a MotionView and a postprocessing window next to each other, split the screen by making use of the Page Window Layout.
Then click into the new window and activate e.g. HyperView through the Client selector as shown below.

In HyperView the three animation types are available: transient, linear, and modal.

**Transient**

Transient animation displays the model in its time step positions as calculated by the analysis code. Transient animation is used to animate the transient response of a structure.

**Linear**

Linear animation creates and displays an animation sequence that starts with the original position of the model and ends with the fully deformed position of the structure. An appropriate number of frames are linearly interpolated between the first and last positions. Linear animation is usually selected when results are from a static analysis.

**Modal**

Modal animation creates and displays an animation sequence that starts and ends with the original position of the structure. The deforming frames are calculated based on a sinusoidal function. Modal animation is most useful for displaying mode shapes.

Click the **Animation Controls** icon, on the Animation toolbar. From this panel, you can control the parameters like speed, start time, end time of the animation.
Some helpful postprocessing “features” are summarized next. Their application is rather straightforward, hence we don’t go into details here. However, you should keep these options in mind while postprocessing and presenting your results.

**Tracing Entities.**

HyperView allows you to trace the path of any moving part while animating.

To turn the tracing off, click the **Delete** button to remove the selected components from the tracing list. You may use the Display Options in the right part of the same panel to change the line color and thickness.

**Tracking Entities**

The Tracking option allows one of the parts of the animation to be **fixed** to the center of the animation window and the rest of the parts move relative to the tracked part.

**Editing Entity Attributes**

The transparent mode is applied to the wheel, wheel hub, and lower control arm. Quite clearly the components, structures in the background become much more visible.
In the following you will learn how to:

- View force and moment vectors from a MotionSolve results file.
- Use the collision detection feature
- Use the measure panel to extract information from the animation results

**Force and Moment Graphics**

HyperView allows you to view the change in force and moment in the form of dynamic vectors that represent the magnitude and direction of the force and moment.

In this brief overview we load the MotionSolve result file front_ride.h3d which is part of the HyperWorks installation (tutorials\mv_hv_hg\mbd_modeling\animation\).

Click on Vector icon, on the toolbar.

Select result type to “Force”, under “Display” options: select By Magnitude for Size scaling. Force symbols can be scaled by a user defined factor. Start the animation.

You will see an arrow whose size and direction change dynamically as the simulation is animated from start to end. This arrow represents the magnitude and direction of force on a body or at a joint as it is specified for force output in the model.

Click on the “Clear Vector” button to clear the force vector.
The Measure Panel

HyperView allows you to measure certain parameters during post processing of the results.

Click on the Measure button,  

Under “Measure Groups” (left side) click on “Add” to add a Measure Group.

From the measure type pull-down menu select Position. Click on the Nodes button and from the graphic window pick on a point of your choice. Turn on the check boxes for X, Y and Z.

Click the Create Curves button (located on the right side of the panel) which opens the Create Curves dialog.

From the “Place” on drop-down menu select New Plot. For the Y Axis: select Z (vertical displacement) and activate the Live link check box and finally click OK.

Note The Live link helps you correlate the measured value with the animation. As you animate the current animation model a small square marker moves on the measured curve to indicate the value of the curve at the corresponding time step of the animation.

Repeat this simple process twice more by selecting Y and X respectively. Depending whether the additional curves should be included in the same plot/graph or in a new one the “Place” option must be set as “Existing” and “New”, respectively.

Click the Start/Pause Animation icon,  to start the animating the results. A marker (square symbol) will be displayed on the plot(s) at the corresponding time step in the simulation.
15.2 HyperGraph - Plotting Basics

In this tutorial you will learn to:

- Import a MotionSolve result (plot) file for plotting curves
- Plot multiple curves in a single window
- Plot multiple curves in different windows on a single page
- Save your work as a session (mvw) file

This all will be accomplished by using HyperGraph.

As in the case of HyperView (animating results) described in the paragraph before, simply select the Client HyperGraph.

The Build Plots panel allows you to import plot files that can be plotted in a 2D layout. The panel allows you to control what curves are to be plotted either in single or multiple windows.
In the course of this short tutorial (which refers to MV-6000: Plotting Basics) we

click the Build Plots icon, 

on the toolbar and load from your HyperWorks installation folder  \tutorials\mv_hv_hg\ mbd_modeling\plotting\ the file Demo.plt

This file contains several curves.

Confirm that **Time** is selected under **X Type**.

For **Y Type**: click on Displacement to select it.

The **Y Request** text box displays the data available in the file.

Press CTRL button on the keyboard and click on REQ/70000006 and REQ/70000007 (or left-click and drag the mouse to select both REQ/70000006 and REQ/70000007)

Select X under **Y Component**

Then set **Layout** as one plot per Component.

Two curves (because of the Y Requests) are plotted in the plot window, each with its own line type and color. The legend identifying the curves is located in the upper right hand corner of the plot.
Build Multiple Curves On Multiple Plots Using The Plot File

In this step you will select multiple curves and plot them in multiple windows.

Stay in Build Plots panel.

Leave Time selected under X

Leave Displacement selected under Y Type

Leave REQ/70000006, and REQ/70000007 selected under Y Request (Up to here the selection/setting corresponds to the steps from before)

Press CTRL and under Y Component: select X, RX, MAG and RMAG.

Select One plot per Component from the Layout pull down menu located in the lower left corner of the panel (see above). This selection creates one plot for every request selected under Y component. There will be four plots created. You could have one page for each plot. However, in the course of this exercise we are going to plot all four plots on the same page.

Hereto we need to define a corresponding Page Layout, located next to the Show Legends check box.

Select the four window layout option.

A second page is added to the page list with four windows and the plots you requested.

This second page can be accessed by clicking on the arrow pointing to the right.
To Save This Work Session

You can save your work with multiple curves in multiple windows on multiple pages as a session file. A session allows later retrieval either for display, printing, or to continue adding more information. The session file is a script with the extension .mvw. The contents of an .mvw file are all the information in the program that gets recorded in the script file.

**Note** To save a session as a script file with curve data: select the Options panel icon from the Annotations toolbar,

and activate the Save All Curve Data To Script File check box (located on the Session tab).

Then from the File menu, select Save As > Session, provide a file name e.g. Demo1.mvw (confirm that Session (*.mvw) is selected from the Save as type drop-down menu).

That’s all it takes.

For more tutorials regarding HyperGraph, please review your installation (Help Documentation):
The HyperGraph tutorial model files are located in `<install_directory>/tutorials/mv_hv_hg`.

**Plotting Basics**
- HG-1000: Plotting XY Data
- HG-1010: Changing Curve Display Attributes
- HG-1020: Modifying Plots
- HG-1030: Referencing and Filtering Curves

**Advanced Curve Manipulation**
- HG-2000: Evaluating Curve Data
- HG-2010: Creating a Plot Macro

**More Plotting**
- HG-3000: Working with Bar Charts
- HG-3010: Working with Complex Plots
- HG-3020: Working with Polar Plots

**Templates**
- HG-4000: Creating an Export Template

**Customization**
- HG-5010: Customizing the Environment
15.3 **HyperView Collision Detection**

**HyperView** allows you to view and detect collisions between the graphic objects of the current animation model during simulations.

Select Tools toolbar from View > Toolbars > **HyperView** > Tools to display collision detection toolbar.

To access the panel shown below, click on the Collision Detection button on the Tools toolbar, or select Collision Detection from the Tools menu.

<table>
<thead>
<tr>
<th><strong>Collision Sets</strong></th>
<th>The collision sets defined for the current model are listed in the Collision Sets list. A collision set is activated, or deactivated, using the radio button. Activating the Clear Collision Detection option clears the contour for the collision detection results, and deactivates all of the collision sets listed. Each collision set is defined by two groups, A and B. A group can contain more than one component.</th>
</tr>
</thead>
</table>
Selection
The Components input collector allows you to select the components that you want to add to the existing groups. Once the components are selected, click the appropriate Add to Group button to add the component to a specific group.

Proximity
Check Enable proximity checking to allow the objects to be detected at the distance specified in the Minimum Distance field.
If Enable proximity checking is unchecked, the objects will collide at their actual collision point and will be displayed in the color red.

Animation Event
These options allow you to define how the objects animate with respect to the collision point.

<table>
<thead>
<tr>
<th>Ignore Collisions</th>
<th>Continuous animation, which ignores the collision point.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stop on Collision</td>
<td>Animation stops when a collision is detected.</td>
</tr>
<tr>
<td>Stop on Proximity Violation</td>
<td>Animation stops when a defined proximity violation is detected.</td>
</tr>
</tbody>
</table>

Workflow
- Click the Add button in the leftmost column under Collision Sets to add a new collision set.
- Under the Selection options (second column) click on the Components button and pick the component of interest (here: Trunk, green) by clicking on it in the Graphics window.
- Click the Add to Group A button (third column)
- Click Components again and pick the other component of interest (here: car body, blue).
- Click the Add to Group B button.
- Under the Proximity section (fourth column), click Enable Proximity checking and specify 1 as the Minimum Distance for the proximity check.

Under the Show result by (fourth column) section select Elements by clicking on the radio button next to it.
- Click Apply.
- Click the Start/Pause Animation icon to start the animation. The animation begins. Whichever areas of the trunklid collide with the trunk (car body), the colliding elements turn red. The color yellow indicates proximity. When neither proximity nor collision is detected, the bodies retain their natural colors.
• Click on Summary below to get a text summary of the penetration.